{"action":"Upgrade apache-airflow to 2.7.1 or later.","affected":[{"fixed":"2.7.1","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2023-40611"],"ecosystem":"PyPI","epss":0.01741,"exploited":false,"fixed_versions":["2.7.1"],"ghsa_id":"GHSA-wpg8-mf6h-gm92","id":"tcs_01M5KG2K7XEDD7M0F2Y4H24AB0","modified_at":"2025-02-13T19:35:44.721761Z","published_at":"2023-09-12T18:58:34Z","references":["https://osv.dev/vulnerability/GHSA-wpg8-mf6h-gm92","https://nvd.nist.gov/vuln/detail/CVE-2023-40611","https://github.com/apache/airflow/pull/33413","https://github.com/apache/airflow/commit/2a0106e4edf67c5905ebfcb82a6008662ae0f7ad","https://github.com/apache/airflow/commit/b7a46c970d638028a4a7643ad000dcee951fb9ef","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-170.yaml","https://lists.apache.org/thread/8y9xk1s3j4qr36yzqn8ogbn9fl7pxrn0","http://www.openwall.com/lists/oss-security/2023/11/12/1"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-wpg8-mf6h-gm92","url":"https://osv.dev/vulnerability/GHSA-wpg8-mf6h-gm92"}],"summary":"Apache Airflow Incorrect Authorization vulnerability"}