{"action":"Upgrade tensorflow-cpu to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-35993"],"ecosystem":"PyPI","epss":0.00478,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-wq6q-6m32-9rv9","id":"tcs_01M5KG2P0F0BN7CTWA79JN7VRB","modified_at":"2026-07-13T16:43:28.079872678Z","published_at":"2022-09-16T22:14:09Z","references":["https://osv.dev/vulnerability/GHSA-wq6q-6m32-9rv9","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wq6q-6m32-9rv9","https://nvd.nist.gov/vuln/detail/CVE-2022-35993","https://github.com/tensorflow/tensorflow/commit/cf70b79d2662c0d3c6af74583641e345fc939467","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-wq6q-6m32-9rv9#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-wq6q-6m32-9rv9"}],"summary":"TensorFlow vulnerable to `CHECK` fail in `SetSize`"}