{"action":"Upgrade ironic to 35.0.1 or later.","affected":[{"fixed":"35.0.1","introduced":"0"}],"component":"ironic","cve_ids":["CVE-2026-42510"],"ecosystem":"PyPI","epss":0.00567,"exploited":false,"fixed_versions":["35.0.1"],"ghsa_id":"GHSA-wqpv-c3pp-3m58","id":"tcs_01M5KG2S7HNWAK1F18NHCDA6GT","modified_at":"2026-09-10T03:51:03.838123142Z","published_at":"2026-04-28T06:30:29Z","references":["https://osv.dev/vulnerability/GHSA-wqpv-c3pp-3m58","https://nvd.nist.gov/vuln/detail/CVE-2026-42510","https://bugs.launchpad.net/ironic/+bug/2148331","https://github.com/openstack/ironic","https://security.openstack.org/ossa/OSSA-2026-008.html","http://www.openwall.com/lists/oss-security/2026/04/30/1"],"severity":{"label":"medium","score":6.6},"sources":[{"source":"osv","source_id":"GHSA-wqpv-c3pp-3m58","url":"https://osv.dev/vulnerability/GHSA-wqpv-c3pp-3m58"}],"summary":"OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere"}