{"action":"Upgrade apache-superset to 3.0.4 or later.","affected":[{"fixed":"3.0.4","introduced":"0"},{"fixed":"3.1.1","introduced":"3.1.0"}],"component":"apache-superset","cve_ids":["CVE-2024-24779"],"ecosystem":"PyPI","epss":0.00733,"exploited":false,"fixed_versions":["3.0.4","3.1.1"],"ghsa_id":"GHSA-wr6g-9wcr-cmqj","id":"tcs_01M5KG2SW19RW101HNPNYTVN40","modified_at":"2026-07-07T17:57:01.497705928Z","published_at":"2024-02-28T12:30:27Z","references":["https://osv.dev/vulnerability/GHSA-wr6g-9wcr-cmqj","https://nvd.nist.gov/vuln/detail/CVE-2024-24779","https://github.com/apache/superset","https://lists.apache.org/thread/xzhz1m5bb9zxhyqgoy4q2d689b3zp4pq","http://www.openwall.com/lists/oss-security/2024/02/28/6"],"severity":{"label":"medium","score":5},"sources":[{"source":"osv","source_id":"GHSA-wr6g-9wcr-cmqj","url":"https://osv.dev/vulnerability/GHSA-wr6g-9wcr-cmqj"}],"summary":"Apache Superset: Improper data authorization when creating a new dataset"}