{"action":"Upgrade calibreweb to 0.6.15 or later.","affected":[{"fixed":"0.6.15","introduced":"0"}],"component":"calibreweb","cve_ids":["CVE-2021-4170"],"ecosystem":"PyPI","epss":0.00809,"exploited":false,"fixed_versions":["0.6.15"],"ghsa_id":"GHSA-wrp6-9w7f-3wxg","id":"tcs_01M5KG2VB39HS025EJWSR61H30","modified_at":"2026-07-06T08:11:13.446574539Z","published_at":"2022-01-21T23:55:34Z","references":["https://osv.dev/vulnerability/GHSA-wrp6-9w7f-3wxg","https://nvd.nist.gov/vuln/detail/CVE-2021-4170","https://github.com/janeczku/calibre-web/commit/7ad419dc8c12180e842a82118f4866ac3d074bc5","https://github.com/janeczku/calibre-web","https://huntr.dev/bounties/ff395101-e392-401d-ab4f-579c63fbf6a0"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-wrp6-9w7f-3wxg","url":"https://osv.dev/vulnerability/GHSA-wrp6-9w7f-3wxg"}],"summary":"calibre-web is vulnerable to Cross-site Scripting"}