{"action":"Upgrade langchain to 0.0.225 or later.","affected":[{"fixed":"0.0.225","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-34540"],"ecosystem":"PyPI","epss":0.01667,"exploited":false,"fixed_versions":["0.0.225"],"ghsa_id":"GHSA-x32c-59v5-h7fg","id":"tcs_01M5KG37TMVTBJP0ZW8HPW6CVX","modified_at":"2025-02-21T05:28:32.059487Z","published_at":"2023-06-14T15:30:39Z","references":["https://osv.dev/vulnerability/GHSA-x32c-59v5-h7fg","https://nvd.nist.gov/vuln/detail/CVE-2023-34540","https://github.com/hwchase17/langchain/issues/4833","https://github.com/langchain-ai/langchain/issues/4833","https://github.com/langchain-ai/langchain/pull/6992","https://github.com/langchain-ai/langchain/commit/a2f191a32229256dd41deadf97786fe41ce04cbb","https://github.com/langchain-ai/langchain","https://github.com/langchain-ai/langchain/releases/tag/v0.0.225","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-91.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-x32c-59v5-h7fg","url":"https://osv.dev/vulnerability/GHSA-x32c-59v5-h7fg"}],"summary":"Langchain OS Command Injection vulnerability"}