{"action":"Upgrade vllm to 0.19.1 or later.","affected":[{"fixed":"0.19.1","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-7141"],"ecosystem":"PyPI","epss":0.00289,"exploited":false,"fixed_versions":["0.19.1"],"ghsa_id":"GHSA-x368-4g9h-fvv4","id":"tcs_01M5KG38K53K1A51FA1MKSWSQH","modified_at":"2026-09-10T03:51:03.823042016Z","published_at":"2026-04-27T18:32:09Z","references":["https://osv.dev/vulnerability/GHSA-x368-4g9h-fvv4","https://nvd.nist.gov/vuln/detail/CVE-2026-7141","https://github.com/vllm-project/vllm/issues/39146","https://github.com/vllm-project/vllm/issues/39146#issue-4215090365","https://github.com/vllm-project/vllm/pull/39283","https://github.com/AjAnubolu/vllm/commit/1ad67864c0c20f167929e64c875f5c28e1aad9fd","https://vuldb.com/submit/801297","https://vuldb.com/vuln/359740","https://vuldb.com/vuln/359740/cti"],"severity":{"label":"medium","score":5.6},"sources":[{"source":"osv","source_id":"GHSA-x368-4g9h-fvv4","url":"https://osv.dev/vulnerability/GHSA-x368-4g9h-fvv4"}],"summary":"vLLM makes Use of Uninitialized Resource"}