{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21738"],"ecosystem":"PyPI","epss":0.00789,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-x4qx-4fjv-hmw6","id":"tcs_01M5KG3FTA64HGVRB794F65V0W","modified_at":"2026-09-10T03:49:12.405343171Z","published_at":"2022-02-09T23:45:09Z","references":["https://osv.dev/vulnerability/GHSA-x4qx-4fjv-hmw6","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x4qx-4fjv-hmw6","https://nvd.nist.gov/vuln/detail/CVE-2022-21738","https://github.com/tensorflow/tensorflow/commit/6f4d3e8139ec724dbbcb40505891c81dd1052c4a","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-62.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-117.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/count_ops.cc#L168-L273"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-x4qx-4fjv-hmw6#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-x4qx-4fjv-hmw6"}],"summary":"Integer overflow leading to crash in Tensorflow"}