{"action":"Upgrade aws-encryption-sdk to 1.9.0 or later.","affected":[{"fixed":"1.9.0","introduced":"0"},{"fixed":"2.2.0","introduced":"2.0.0"}],"component":"aws-encryption-sdk","cve_ids":[],"ecosystem":"PyPI","exploited":false,"fixed_versions":["1.9.0","2.2.0"],"ghsa_id":"GHSA-x5h4-9gqw-942j","id":"tcs_01M5KG3HE845VYZ2GA07NJPR80","modified_at":"2024-12-02T05:55:27.847029Z","published_at":"2021-06-01T21:17:53Z","references":["https://osv.dev/vulnerability/GHSA-x5h4-9gqw-942j","https://github.com/aws/aws-encryption-sdk-python/security/advisories/GHSA-x5h4-9gqw-942j"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-x5h4-9gqw-942j","url":"https://osv.dev/vulnerability/GHSA-x5h4-9gqw-942j"}],"summary":"Improper Verification of Cryptographic Signature in aws-encryption-sdk"}