{"action":"Upgrade apache-airflow-providers-mongo to 4.0.0 or later.","affected":[{"fixed":"4.0.0","introduced":"0"}],"component":"apache-airflow-providers-mongo","cve_ids":["CVE-2024-25141"],"ecosystem":"PyPI","epss":0.00625,"exploited":false,"fixed_versions":["4.0.0"],"ghsa_id":"GHSA-x5pm-h33q-cjrw","id":"tcs_01M5KG3J0KTW4SRQJR01B2SFNJ","modified_at":"2026-10-26T21:30:05.353696502Z","published_at":"2024-02-20T21:30:26Z","references":["https://osv.dev/vulnerability/GHSA-x5pm-h33q-cjrw","https://nvd.nist.gov/vuln/detail/CVE-2024-25141","https://github.com/apache/airflow/pull/37214","https://github.com/apache/airflow","https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm","http://www.openwall.com/lists/oss-security/2024/02/20/5","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-mongo/PYSEC-2026-278.yaml","https://pypi.org/project/apache-airflow-providers-mongo"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-x5pm-h33q-cjrw","url":"https://osv.dev/vulnerability/GHSA-x5pm-h33q-cjrw"}],"summary":"Improper Certificate Validation in apache airflow mongo hook"}