{"action":"Upgrade gevent to 23.9.0 or later.","affected":[{"fixed":"23.9.0","introduced":"0"}],"component":"gevent","cve_ids":["CVE-2023-41419"],"ecosystem":"PyPI","epss":0.01793,"exploited":false,"fixed_versions":["23.9.0"],"ghsa_id":"GHSA-x7m3-jprg-wc5g","id":"tcs_01M5KG3PKPSXYDM664WW8RR6R4","modified_at":"2026-09-10T03:50:03.449280541Z","published_at":"2023-09-25T12:30:44Z","references":["https://osv.dev/vulnerability/GHSA-x7m3-jprg-wc5g","https://nvd.nist.gov/vuln/detail/CVE-2023-41419","https://github.com/gevent/gevent/issues/1989","https://github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c","https://github.com/gevent/gevent","https://github.com/pypa/advisory-database/tree/main/vulns/gevent/PYSEC-2023-177.yaml","https://lists.debian.org/debian-lts-announce/2025/11/msg00020.html","http://www.gevent.org/changelog.html"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-x7m3-jprg-wc5g","url":"https://osv.dev/vulnerability/GHSA-x7m3-jprg-wc5g"}],"summary":"Gevent allows remote attacker to escalate privileges"}