{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29580"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-x8h6-xgqx-jqgp","id":"tcs_01M5KG3V9VJT86EDPP2SRN46ZX","modified_at":"2026-07-08T06:28:40.590448452Z","published_at":"2021-05-21T14:26:26Z","references":["https://osv.dev/vulnerability/GHSA-x8h6-xgqx-jqgp","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x8h6-xgqx-jqgp","https://nvd.nist.gov/vuln/detail/CVE-2021-29580","https://github.com/tensorflow/tensorflow/commit/32fdcbff9d06d010d908fcc4bd4b36eb3ce15925","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-508.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-706.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-217.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-x8h6-xgqx-jqgp#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-x8h6-xgqx-jqgp"}],"summary":"Undefined behavior and `CHECK`-fail in `FractionalMaxPoolGrad`"}