{"action":"Upgrade @strapi/plugin-upload to 4.22.0 or later.","affected":[{"fixed":"4.22.0","introduced":"0"}],"component":"@strapi/plugin-upload","cve_ids":["CVE-2024-31217"],"ecosystem":"npm","epss":0.00736,"exploited":false,"fixed_versions":["4.22.0"],"ghsa_id":"GHSA-pm9q-xj9p-96pm","id":"tcs_01M5KG3YD2RCNMWTYHWJWJGRXA","modified_at":"2026-09-10T03:50:15.685130610Z","published_at":"2024-06-12T19:38:24Z","references":["https://osv.dev/vulnerability/GHSA-pm9q-xj9p-96pm","https://github.com/strapi/strapi/security/advisories/GHSA-pm9q-xj9p-96pm","https://nvd.nist.gov/vuln/detail/CVE-2024-31217","https://github.com/strapi/strapi/commit/a0da7e73e1496d835fe71a2febb14f70170135c7","https://github.com/strapi/strapi"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-pm9q-xj9p-96pm","url":"https://osv.dev/vulnerability/GHSA-pm9q-xj9p-96pm"}],"summary":"@strapi/plugin-upload has a Denial-of-Service via Improper Exception Handling"}