{"action":"Upgrade executorch to 0.7.0 or later.","affected":[{"fixed":"0.7.0","introduced":"0"}],"component":"executorch","cve_ids":["CVE-2025-54951"],"ecosystem":"PyPI","epss":0.00708,"exploited":false,"fixed_versions":["0.7.0"],"ghsa_id":"GHSA-xc7w-r669-48pf","id":"tcs_01M5KG3ZX748S53DC42DGQT42P","modified_at":"2026-10-27T16:45:04.559235269Z","published_at":"2025-08-08T00:30:26Z","references":["https://osv.dev/vulnerability/GHSA-xc7w-r669-48pf","https://nvd.nist.gov/vuln/detail/CVE-2025-54951","https://github.com/pytorch/executorch/commit/cea9b23aa8ff78aff92829a466da97461cc7930c","https://github.com/pytorch/executorch","https://www.facebook.com/security/advisories/cve-2025-54951","https://github.com/pypa/advisory-database/tree/main/vulns/executorch/PYSEC-2026-336.yaml","https://pypi.org/project/executorch"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-xc7w-r669-48pf","url":"https://osv.dev/vulnerability/GHSA-xc7w-r669-48pf"}],"summary":"ExecuTorch vulnerable to Heap-based Buffer Overflow"}