{"action":"Upgrade github.com/gorilla/schema to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0"}],"component":"github.com/gorilla/schema","cve_ids":["CVE-2024-37298"],"ecosystem":"Go","epss":0.01096,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-3669-72x9-r9p3","id":"tcs_01M5KG41F7DW2AQ4ZP6NP13A99","modified_at":"2026-02-04T02:53:15.821632Z","published_at":"2024-07-02T19:19:24Z","references":["https://osv.dev/vulnerability/GO-2024-2958","https://github.com/gorilla/schema/security/advisories/GHSA-3669-72x9-r9p3","https://github.com/gorilla/schema/commit/cd59f2f12cbdfa9c06aa63e425d1fe4a806967ff","https://github.com/gorilla/schema/blob/main/decoder.go#L223"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2024-2958","url":"https://osv.dev/vulnerability/GO-2024-2958"}],"summary":"Potential memory exhaustion attack due to sparse slice deserialization in github.com/gorilla/schema"}