{"action":"Upgrade riot-compiler to 2.3.22 or later.","affected":[{"fixed":"2.3.22","introduced":"0"}],"component":"riot-compiler","cve_ids":["CVE-2016-10527"],"ecosystem":"npm","epss":0.01573,"exploited":false,"fixed_versions":["2.3.22"],"ghsa_id":"GHSA-pp4v-55vr-9gxh","id":"tcs_01M5KG42XXCSSE5TW5JESJT23H","modified_at":"2023-11-08T03:58:10.661609Z","published_at":"2019-02-18T23:39:13Z","references":["https://osv.dev/vulnerability/GHSA-pp4v-55vr-9gxh","https://nvd.nist.gov/vuln/detail/CVE-2016-10527","https://github.com/riot/compiler/issues/46","https://github.com/advisories/GHSA-pp4v-55vr-9gxh","https://www.npmjs.com/advisories/86"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-pp4v-55vr-9gxh","url":"https://osv.dev/vulnerability/GHSA-pp4v-55vr-9gxh"}],"summary":"Regular Expression Denial of Service in riot-compiler"}