{"action":"Upgrade @dynatrace-oss/dynatrace-mcp-server to 2.1.1 or later.","affected":[{"fixed":"2.1.1","introduced":"0"}],"component":"@dynatrace-oss/dynatrace-mcp-server","cve_ids":[],"ecosystem":"npm","exploited":false,"fixed_versions":["2.1.1"],"ghsa_id":"GHSA-pqh8-p93p-2rx7","id":"tcs_01M5KG47WV83MDB65VTHKKZF33","modified_at":"2026-07-31T16:01:14.949107357Z","published_at":"2026-07-31T15:56:12Z","references":["https://osv.dev/vulnerability/GHSA-pqh8-p93p-2rx7","https://github.com/dynatrace-oss/dynatrace-mcp/security/advisories/GHSA-pqh8-p93p-2rx7","https://github.com/dynatrace-oss/dynatrace-mcp/pull/562","https://github.com/dynatrace-oss/dynatrace-mcp/commit/15d3546c0618ffbaeaeca477337e08e92f2151bc","https://github.com/dynatrace-oss/dynatrace-mcp","https://github.com/dynatrace-oss/dynatrace-mcp/releases/tag/v2.1.1"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-pqh8-p93p-2rx7","url":"https://osv.dev/vulnerability/GHSA-pqh8-p93p-2rx7"}],"summary":"@dynatrace-oss/dynatrace-mcp-server has a DQL injection via parameters not documented as DQL"}