{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29525"],"ecosystem":"PyPI","epss":0.00201,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-xm2v-8rrw-w9pm","id":"tcs_01M5KG4CGCCYS268GCZWCTD95B","modified_at":"2026-09-10T03:49:15.207713645Z","published_at":"2021-05-21T14:21:51Z","references":["https://osv.dev/vulnerability/GHSA-xm2v-8rrw-w9pm","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xm2v-8rrw-w9pm","https://nvd.nist.gov/vuln/detail/CVE-2021-29525","https://github.com/tensorflow/tensorflow/commit/2be2cdf3a123e231b16f766aa0e27d56b4606535","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-453.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-651.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-162.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-xm2v-8rrw-w9pm#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-xm2v-8rrw-w9pm"}],"summary":"Division by 0 in `Conv2DBackpropInput`"}