{"action":"Upgrade @angular/core to 19.2.19 or later.","affected":[{"fixed":"21.2.0","introduced":"21.2.0-next.0"},{"fixed":"21.1.6","introduced":"21.0.0-next.0"},{"fixed":"20.3.17","introduced":"20.0.0-next.0"},{"fixed":"19.2.19","introduced":"19.0.0-next.0"},{"introduced":"0","last_affected":"18.2.14"}],"component":"@angular/core","cve_ids":["CVE-2026-27970"],"ecosystem":"npm","epss":0.00547,"exploited":false,"fixed_versions":["21.2.0","21.1.6","20.3.17","19.2.19"],"ghsa_id":"GHSA-prjf-86w9-mfqv","id":"tcs_01M5KG4DAV6Z2JC74M99J8ZQ1E","modified_at":"2026-09-10T03:50:59.526027948Z","published_at":"2026-02-27T18:33:16Z","references":["https://osv.dev/vulnerability/GHSA-prjf-86w9-mfqv","https://github.com/angular/angular/security/advisories/GHSA-prjf-86w9-mfqv","https://nvd.nist.gov/vuln/detail/CVE-2026-27970","https://github.com/angular/angular/pull/67183","https://github.com/angular/angular/commit/306f367899dfc2e04238fecd3455547b5d54075d","https://github.com/angular/angular/commit/7d58b798c626bb0e4e5f89ca8affdce4f352b232","https://github.com/angular/angular/commit/b85830953281ff3a1a77bbfe69019d352d509c93","https://angular.dev/best-practices/security#enforcing-trusted-types","https://developer.mozilla.org/en-US/docs/Web/API/Trusted_Types_API","https://developer.mozilla.org/en-US/docs/Web/HTTP/Guides/CSP","https://developer.mozilla.org/en-US/docs/Web/Security/Attacks/XSS","https://github.com/angular/angular"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-prjf-86w9-mfqv","url":"https://osv.dev/vulnerability/GHSA-prjf-86w9-mfqv"}],"summary":"Angular i18n vulnerable to Cross-Site Scripting"}