{"action":"Upgrade github.com/charmbracelet/soft-serve to 0.7.5 or later.","affected":[{"fixed":"0.7.5","introduced":"0"}],"component":"github.com/charmbracelet/soft-serve","cve_ids":["CVE-2024-41956"],"ecosystem":"Go","epss":0.00509,"exploited":false,"fixed_versions":["0.7.5"],"ghsa_id":"GHSA-m445-w3xr-vp2f","id":"tcs_01M5KG4F7Y0F4J4R1KQHTT5B3V","modified_at":"2026-03-03T04:55:36.530648Z","published_at":"2024-08-06T22:03:16Z","references":["https://osv.dev/vulnerability/GO-2024-3019","https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-m445-w3xr-vp2f","https://nvd.nist.gov/vuln/detail/CVE-2024-41956","https://github.com/charmbracelet/soft-serve/commit/4daebdd422a6ba8c04162d023f8be355a8fe3184"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2024-3019","url":"https://osv.dev/vulnerability/GO-2024-3019"}],"summary":"soft-serve vulnerable to arbitrary code execution by crafting git-lfs requests in github.com/charmbracelet/soft-serve"}