{"action":"Upgrade mathjs to 3.17.0 or later.","affected":[{"fixed":"3.17.0","introduced":"0"}],"component":"mathjs","cve_ids":["CVE-2017-1001003"],"ecosystem":"npm","epss":0.01689,"exploited":false,"fixed_versions":["3.17.0"],"ghsa_id":"GHSA-pv8x-p9hq-j328","id":"tcs_01M5KG4FRWQDYYXZ76MVE7A5YZ","modified_at":"2023-11-08T03:58:48.069147Z","published_at":"2017-12-18T22:27:53Z","references":["https://osv.dev/vulnerability/GHSA-pv8x-p9hq-j328","https://nvd.nist.gov/vuln/detail/CVE-2017-1001003","https://github.com/josdejong/mathjs/commit/a60f3c8d9dd714244aed7a5569c3dccaa3a4e761","https://github.com/advisories/GHSA-pv8x-p9hq-j328","https://github.com/josdejong/mathjs/blob/master/HISTORY.md#2017-11-18-version-3170","https://www.npmjs.com/advisories/551"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-pv8x-p9hq-j328","url":"https://osv.dev/vulnerability/GHSA-pv8x-p9hq-j328"}],"summary":"Arbitrary Code Execution in mathjs"}