{"action":"Upgrade npm-user-validate to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"npm-user-validate","cve_ids":["CVE-2020-7754"],"ecosystem":"npm","epss":0.03481,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-pw54-mh39-w3hc","id":"tcs_01M5KG4JRPBYKMBA3CGCVAFA65","modified_at":"2026-07-08T06:49:44.248240618Z","published_at":"2021-05-10T19:08:15Z","references":["https://osv.dev/vulnerability/GHSA-pw54-mh39-w3hc","https://github.com/npm/npm-user-validate/security/advisories/GHSA-xgh6-85xh-479p","https://nvd.nist.gov/vuln/detail/CVE-2020-7754","https://github.com/npm/npm-user-validate/commit/c8a87dac1a4cc6988b5418f30411a8669bef204e","https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1019353","https://snyk.io/vuln/SNYK-JS-NPMUSERVALIDATE-1019352"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-pw54-mh39-w3hc","url":"https://osv.dev/vulnerability/GHSA-pw54-mh39-w3hc"}],"summary":"Regular expression denial of service in npm-user-validate"}