{"action":"Upgrade tensorflow to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow","cve_ids":["CVE-2021-29618"],"ecosystem":"PyPI","epss":0.0023,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-xqfj-cr6q-pc8w","id":"tcs_01M5KG4KGQQ48SJP9QVBAYBA4M","modified_at":"2026-09-10T03:49:15.039878286Z","published_at":"2021-05-21T14:28:58Z","references":["https://osv.dev/vulnerability/GHSA-xqfj-cr6q-pc8w","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xqfj-cr6q-pc8w","https://nvd.nist.gov/vuln/detail/CVE-2021-29618","https://github.com/tensorflow/tensorflow/commit/1dc6a7ce6e0b3e27a7ae650bfc05b195ca793f88","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-546.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-744.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-255.yaml","https://github.com/tensorflow/issues/42105","https://github.com/tensorflow/issues/46973","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-xqfj-cr6q-pc8w","url":"https://osv.dev/vulnerability/GHSA-xqfj-cr6q-pc8w"}],"summary":"Crash in `tf.transpose` with complex inputs"}