{"action":"Upgrade poetry to 1.1.9 or later.","affected":[{"fixed":"1.1.9","introduced":"0"}],"component":"poetry","cve_ids":["CVE-2022-26184"],"ecosystem":"PyPI","epss":0.0185,"exploited":false,"fixed_versions":["1.1.9"],"ghsa_id":"GHSA-xr2c-5w89-63pv","id":"tcs_01M5KG4MYZR5F0XJC8ZKVG90MG","modified_at":"2024-10-21T21:26:19.242413Z","published_at":"2022-03-23T00:00:24Z","references":["https://osv.dev/vulnerability/GHSA-xr2c-5w89-63pv","https://nvd.nist.gov/vuln/detail/CVE-2022-26184","https://github.com/python-poetry/poetry-core/pull/205/commits/fa9cb6f358ae840885c700f954317f34838caba7","https://github.com/python-poetry/poetry-core/commit/1e1a109a1009daaab2367ce90c997f0cbbb0c1d1","https://github.com/advisories/GHSA-xr2c-5w89-63pv","https://github.com/pypa/advisory-database/tree/main/vulns/poetry/PYSEC-2022-234.yaml","https://github.com/python-poetry","https://github.com/python-poetry/poetry/releases/tag/1.1.9","https://www.sonarsource.com/blog/securing-developer-tools-package-managers"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-xr2c-5w89-63pv","url":"https://osv.dev/vulnerability/GHSA-xr2c-5w89-63pv"}],"summary":"Poetry before v1.1.9 contains Untrusted Search Path"}