{"action":"Upgrade tensorflow-gpu to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-41202"],"ecosystem":"PyPI","epss":0.00209,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-xrqm-fpgr-6hhx","id":"tcs_01M5KG4QB8EWQTV20B4HVCYX9K","modified_at":"2026-07-08T06:27:31.260668116Z","published_at":"2021-11-10T19:13:16Z","references":["https://osv.dev/vulnerability/GHSA-xrqm-fpgr-6hhx","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xrqm-fpgr-6hhx","https://nvd.nist.gov/vuln/detail/CVE-2021-41202","https://github.com/tensorflow/tensorflow/issues/46889","https://github.com/tensorflow/tensorflow/issues/46912","https://github.com/tensorflow/tensorflow/commit/1b0e0ec27e7895b9985076eab32445026ae5ca94","https://github.com/tensorflow/tensorflow/commit/6d94002a09711d297dbba90390d5482b76113899","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-612.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-810.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-395.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-xrqm-fpgr-6hhx#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-xrqm-fpgr-6hhx"}],"summary":"Overflow/crash in `tf.range`"}