{"action":"Upgrade pygresql to 4.1 or later.","affected":[{"introduced":"0","last_affected":"3.8.1"},{"fixed":"4.1","introduced":"4.0"}],"component":"pygresql","cve_ids":["CVE-2009-2940"],"ecosystem":"PyPI","epss":0.02702,"exploited":false,"fixed_versions":["4.1"],"ghsa_id":"GHSA-xv6x-43gq-4hfj","id":"tcs_01M5KG4RQKVXFWCBG2ZMN9Q9JJ","modified_at":"2026-06-08T19:15:12.507974558Z","published_at":"2022-05-02T03:40:08Z","references":["https://osv.dev/vulnerability/GHSA-xv6x-43gq-4hfj","https://nvd.nist.gov/vuln/detail/CVE-2009-2940","https://github.com/PyGreSQL/PyGreSQL/commit/8e19320b130946eed6f043297e3e4e005a523612","https://github.com/PyGreSQL/PyGreSQL/commit/f7237d773e6f4d5a7da3d99bb6bc5062bd07935e","https://github.com/PyGreSQL/PyGreSQL","https://github.com/pypa/advisory-database/tree/main/vulns/pygresql/PYSEC-2009-18.yaml","http://ubuntu.com/usn/usn-870-1","http://www.debian.org/security/2009/dsa-1911"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-xv6x-43gq-4hfj","url":"https://osv.dev/vulnerability/GHSA-xv6x-43gq-4hfj"}],"summary":"PyGreSQL Might Be Vulnerable to Encoding-Based SQL Injection"}