{"action":"Upgrade datasette to 0.56.1 or later.","affected":[{"fixed":"0.56.1","introduced":"0"}],"component":"datasette","cve_ids":["CVE-2021-32670"],"ecosystem":"PyPI","epss":0.0096,"exploited":false,"fixed_versions":["0.56.1"],"ghsa_id":"GHSA-xw7c-jx9m-xh5g","id":"tcs_01M5KG4VEFYCMS1VQYQNP9QR3B","modified_at":"2026-07-08T06:28:56.693631657Z","published_at":"2021-06-07T21:47:41Z","references":["https://osv.dev/vulnerability/GHSA-xw7c-jx9m-xh5g","https://github.com/simonw/datasette/security/advisories/GHSA-xw7c-jx9m-xh5g","https://github.com/simonw/datasette/issues/1360","https://datasette.io/plugins/datasette-auth-passwords","https://github.com/advisories/GHSA-gff3-739c-gxfq","https://github.com/pypa/advisory-database/tree/main/vulns/datasette/PYSEC-2021-89.yaml","https://github.com/simonw/datasette","https://owasp.org/www-community/attacks/xss/#reflected-xss-attacks","https://pypi.org/project/datasette"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-xw7c-jx9m-xh5g","url":"https://osv.dev/vulnerability/GHSA-xw7c-jx9m-xh5g"}],"summary":"Reflected cross-site scripting issue in Datasette"}