{"action":"Upgrade @lionello/secp256k1-js to 1.1.0 or later.","affected":[{"fixed":"1.1.0","introduced":"0"}],"component":"@lionello/secp256k1-js","cve_ids":["CVE-2022-41340"],"ecosystem":"npm","epss":0.00699,"exploited":false,"fixed_versions":["1.1.0"],"ghsa_id":"GHSA-q3f4-9h4p-vgr3","id":"tcs_01M5KG4XXE3AQFMPN23MAB5SJM","modified_at":"2023-11-08T04:10:29.617592Z","published_at":"2022-09-25T00:00:15Z","references":["https://osv.dev/vulnerability/GHSA-q3f4-9h4p-vgr3","https://nvd.nist.gov/vuln/detail/CVE-2022-41340","https://github.com/lionello/secp256k1-js/issues/11","https://github.com/lionello/secp256k1-js/commit/302800f0370b42e360a33774bb808274ac729c2e","https://github.com/lionello/secp256k1-js","https://github.com/lionello/secp256k1-js/compare/1.0.1...1.1.0","https://www.npmjs.com/package/@lionello/secp256k1-js"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-q3f4-9h4p-vgr3","url":"https://osv.dev/vulnerability/GHSA-q3f4-9h4p-vgr3"}],"summary":"secp256k1-js implements ECDSA without required r and s validation, leading to signature forgery"}