{"action":"Upgrade moin to 1.8.3 or later.","affected":[{"fixed":"1.8.3","introduced":"0"}],"component":"moin","cve_ids":["CVE-2009-1482"],"ecosystem":"PyPI","epss":0.02503,"exploited":false,"fixed_versions":["1.8.3"],"ghsa_id":"GHSA-4pfg-2frf-f67v","id":"tcs_01M5KG58BP2A7H2B9B1063772A","modified_at":"2026-06-10T17:02:22.044629095Z","published_at":"2009-04-29T18:30:00Z","references":["https://osv.dev/vulnerability/PYSEC-2009-6","http://secunia.com/advisories/34821","http://www.vupen.com/english/advisories/2009/1119","http://hg.moinmo.in/moin/1.8/rev/5f51246a4df1","http://www.securityfocus.com/bid/34631","http://moinmo.in/SecurityFixes","http://www.ubuntu.com/usn/USN-774-1","http://secunia.com/advisories/35024","http://secunia.com/advisories/34945","http://www.debian.org/security/2009/dsa-1791","https://exchange.xforce.ibmcloud.com/vulnerabilities/50356","https://github.com/advisories/GHSA-4pfg-2frf-f67v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2009-6","url":"https://osv.dev/vulnerability/PYSEC-2009-6"}],"summary":"Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin 1.8.2 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) an AttachFile sub-action"}