{"action":"Upgrade mako to 0.3.4 or later.","affected":[{"fixed":"0.3.4","introduced":"0"}],"component":"mako","cve_ids":["CVE-2010-2480"],"ecosystem":"PyPI","epss":0.01824,"exploited":false,"fixed_versions":["0.3.4"],"ghsa_id":"GHSA-7q8x-38mc-p84f","id":"tcs_01M5KG590GPHCC63S85FHNC197","modified_at":"2026-06-10T17:00:40.513369422Z","published_at":"2010-07-02T19:00:00Z","references":["https://osv.dev/vulnerability/PYSEC-2010-1","http://bugs.python.org/issue9061","http://secunia.com/advisories/39935","http://www.makotemplates.org/CHANGES","http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html","https://github.com/advisories/GHSA-7q8x-38mc-p84f"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2010-1","url":"https://osv.dev/vulnerability/PYSEC-2010-1"}],"summary":"Mako before 0.3.4 relies on the cgi.escape function in the Python standard library for cross-site scripting (XSS) protection, which makes it easier for remote attackers to conduct XSS attacks via vect"}