{"action":"Upgrade moin to 1.9.3 or later.","affected":[{"fixed":"1.9.3","introduced":"1.9"}],"component":"moin","cve_ids":["CVE-2010-2970"],"ecosystem":"PyPI","epss":0.02551,"exploited":false,"fixed_versions":["1.9.3"],"ghsa_id":"GHSA-gxh5-r8gp-pjc3","id":"tcs_01M5KG5ARE614YYK7D2TKMSB54","modified_at":"2026-06-10T17:02:22.253471290Z","published_at":"2010-08-05T13:22:00Z","references":["https://osv.dev/vulnerability/PYSEC-2010-18","http://marc.info/?l=oss-security&m=127809682420259&w=2","http://www.vupen.com/english/advisories/2010/1981","http://secunia.com/advisories/40836","http://www.securityfocus.com/bid/40549","http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584809","http://moinmo.in/SecurityFixes","http://hg.moinmo.in/moin/1.9/rev/e50b087c4572","http://moinmo.in/MoinMoinRelease1.9","http://moinmo.in/MoinMoinBugs/1.9.2UnescapedInputForThemeAddMsg","http://hg.moinmo.in/moin/1.9/rev/4fe9951788cb","http://marc.info/?l=oss-security&m=127799369406968&w=2","http://www.debian.org/security/2010/dsa-2083","http://hg.moinmo.in/moin/1.9/raw-file/1.9.3/docs/CHANGES","https://github.com/advisories/GHSA-gxh5-r8gp-pjc3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2010-18","url":"https://osv.dev/vulnerability/PYSEC-2010-18"}],"summary":"Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/SlideShow.py"}