{"action":"Upgrade @zenuml/core to 3.23.25 or later.","affected":[{"fixed":"3.23.25","introduced":"0"}],"component":"@zenuml/core","cve_ids":["CVE-2024-38527"],"ecosystem":"npm","epss":0.00381,"exploited":false,"fixed_versions":["3.23.25"],"ghsa_id":"GHSA-q6xv-jm4v-349h","id":"tcs_01M5KG5H2P94BZ3HGJ4W4SMJTH","modified_at":"2026-09-10T03:50:15.788918610Z","published_at":"2024-06-26T19:03:54Z","references":["https://osv.dev/vulnerability/GHSA-q6xv-jm4v-349h","https://github.com/mermaid-js/zenuml-core/security/advisories/GHSA-q6xv-jm4v-349h","https://nvd.nist.gov/vuln/detail/CVE-2024-38527","https://github.com/mermaid-js/zenuml-core/commit/ad7545b33f5f27466cbf357beb65969ca1953e3c","https://github.com/mermaid-js/zenuml-core"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-q6xv-jm4v-349h","url":"https://osv.dev/vulnerability/GHSA-q6xv-jm4v-349h"}],"summary":"Cross-site Scripting in ZenUML"}