{"action":"Upgrade beaker to 1.6.5.post1 or later.","affected":[{"fixed":"1.6.5.post1","introduced":"0"}],"component":"beaker","cve_ids":["CVE-2012-3458"],"ecosystem":"PyPI","epss":0.02467,"exploited":false,"fixed_versions":["1.6.5.post1"],"ghsa_id":"GHSA-39vm-p9mr-4r27","id":"tcs_01M5KG5K4X75W4BJV7FXMMDZH0","modified_at":"2026-06-10T17:00:38.335141589Z","published_at":"2012-09-15T17:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2012-1","http://www.debian.org/security/2012/dsa-2541","http://secunia.com/advisories/50520","http://www.openwall.com/lists/oss-security/2012/08/13/10","https://github.com/bbangert/beaker/commit/91becae76101cf87ce8cbfabe3af2622fc328fe5","http://secunia.com/advisories/50226","https://bugzilla.redhat.com/show_bug.cgi?id=809267","https://github.com/advisories/GHSA-39vm-p9mr-4r27"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2012-1","url":"https://osv.dev/vulnerability/PYSEC-2012-1"}],"summary":"Beaker before 1.6.4, when using PyCrypto to encrypt sessions, uses AES in ECB cipher mode, which might allow remote attackers to obtain portions of sensitive session data via unspecified vectors."}