{"action":"Upgrade setuptools to 0.7 or later.","affected":[{"fixed":"0.7","introduced":"0"}],"component":"setuptools","cve_ids":["CVE-2013-1633"],"ecosystem":"PyPI","epss":0.0196,"exploited":false,"fixed_versions":["0.7"],"ghsa_id":"GHSA-27x4-j476-jp5f","id":"tcs_01M5KG5SJNQKKS3W84ABHSNGQ6","modified_at":"2026-06-10T17:02:39.576960663Z","published_at":"2013-08-06T02:52:00Z","references":["https://osv.dev/vulnerability/PYSEC-2013-22","http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a/","https://pypi.python.org/pypi/setuptools/0.9.8#changes","https://github.com/advisories/GHSA-27x4-j476-jp5f"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2013-22","url":"https://osv.dev/vulnerability/PYSEC-2013-22"}],"summary":"easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to ex"}