{"action":"Upgrade openclaw to 2026.3.31 or later.","affected":[{"fixed":"2026.3.31","introduced":"0"}],"component":"openclaw","cve_ids":["CVE-2026-41396"],"ecosystem":"npm","epss":0.00126,"exploited":false,"fixed_versions":["2026.3.31"],"ghsa_id":"GHSA-qcj9-wwgw-6gm8","id":"tcs_01M5KG5WZSAG820SDXK7PGM5GW","modified_at":"2026-05-06T02:51:12.043707Z","published_at":"2026-04-03T02:47:57Z","references":["https://osv.dev/vulnerability/GHSA-qcj9-wwgw-6gm8","https://github.com/openclaw/openclaw/security/advisories/GHSA-qcj9-wwgw-6gm8","https://nvd.nist.gov/vuln/detail/CVE-2026-41396","https://github.com/openclaw/openclaw/commit/330a9f98cb29c79b1c16a2117e03d6276a0d6289","https://github.com/openclaw/openclaw","https://github.com/openclaw/openclaw/releases/tag/v2026.3.31","https://www.vulncheck.com/advisories/openclaw-environment-variable-override-of-plugin-trust-root"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-qcj9-wwgw-6gm8","url":"https://osv.dev/vulnerability/GHSA-qcj9-wwgw-6gm8"}],"summary":"OpenClaw: Workspace `.env` can override the bundled plugin trust root"}