{"action":"Upgrade pillow to 2.3.2 or later.","affected":[{"fixed":"2.3.2","introduced":"0"},{"fixed":"2.5.2","introduced":"2.5"}],"component":"pillow","cve_ids":["CVE-2014-3589"],"ecosystem":"PyPI","epss":0.03362,"exploited":false,"fixed_versions":["2.3.2","2.5.2"],"ghsa_id":"GHSA-cfmr-38g9-f2h7","id":"tcs_01M5KG5YHYY3VR88WCPGWKJ0DH","modified_at":"2026-06-10T17:02:31.584099399Z","published_at":"2014-08-25T14:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-10","https://pypi.python.org/pypi/Pillow/2.5.2","https://pypi.python.org/pypi/Pillow/2.3.2","http://www.debian.org/security/2014/dsa-3009","https://github.com/python-pillow/Pillow/commit/205e056f8f9b06ed7b925cf8aa0874bc4aaf8a7d","http://lists.opensuse.org/opensuse-updates/2015-04/msg00056.html","http://secunia.com/advisories/59825","https://github.com/advisories/GHSA-cfmr-38g9-f2h7"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-10","url":"https://osv.dev/vulnerability/PYSEC-2014-10"}],"summary":"PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size."}