{"action":"Upgrade requests to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"0"}],"component":"requests","cve_ids":["CVE-2014-1829"],"ecosystem":"PyPI","epss":0.022,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-cfj3-7x9c-4p3h","id":"tcs_01M5KG60ZDNM70E5TMQ6WE9GGA","modified_at":"2023-11-08T03:57:34.760439Z","published_at":"2014-10-15T14:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-13","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733108","https://github.com/kennethreitz/requests/issues/1885","http://www.ubuntu.com/usn/USN-2382-1","http://www.debian.org/security/2015/dsa-3146","http://www.mandriva.com/security/advisories?name=MDVSA-2015:133","http://advisories.mageia.org/MGASA-2014-0409.html","https://github.com/advisories/GHSA-cfj3-7x9c-4p3h"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-13","url":"https://osv.dev/vulnerability/PYSEC-2014-13"}],"summary":"Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc password by reading the Authorization header in a redirected request."}