{"action":"Upgrade requests to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"0"}],"component":"requests","cve_ids":["CVE-2014-1830"],"ecosystem":"PyPI","epss":0.02036,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-652x-xj99-gmcc","id":"tcs_01M5KG6183ABA9YY63M1VYS9PA","modified_at":"2023-11-08T03:57:34.820933Z","published_at":"2014-10-15T14:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-14","https://github.com/kennethreitz/requests/issues/1885","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733108","http://www.debian.org/security/2015/dsa-3146","http://www.mandriva.com/security/advisories?name=MDVSA-2015:133","http://advisories.mageia.org/MGASA-2014-0409.html","http://lists.opensuse.org/opensuse-updates/2016-01/msg00095.html","https://github.com/advisories/GHSA-652x-xj99-gmcc"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-14","url":"https://osv.dev/vulnerability/PYSEC-2014-14"}],"summary":"Requests (aka python-requests) before 2.3.0 allows remote servers to obtain sensitive information by reading the Proxy-Authorization header in a redirected request."}