{"action":"Upgrade roundup to 1.4.20 or later.","affected":[{"fixed":"1.4.20","introduced":"0"}],"component":"roundup","cve_ids":["CVE-2012-6130"],"ecosystem":"PyPI","epss":0.02,"exploited":false,"fixed_versions":["1.4.20"],"ghsa_id":"GHSA-mccq-3m7h-fjxg","id":"tcs_01M5KG61CPS12980GCCVEVAQGP","modified_at":"2026-06-10T17:02:33.910554908Z","published_at":"2014-04-11T15:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-15","http://issues.roundup-tracker.org/issue2550684","https://pypi.python.org/pypi/roundup/1.4.20","http://www.openwall.com/lists/oss-security/2012/11/10/2","https://bugzilla.redhat.com/show_bug.cgi?id=722672","http://www.openwall.com/lists/oss-security/2013/02/13/8","https://exchange.xforce.ibmcloud.com/vulnerabilities/84189","https://github.com/advisories/GHSA-mccq-3m7h-fjxg"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-15","url":"https://osv.dev/vulnerability/PYSEC-2014-15"}],"summary":"Cross-site scripting (XSS) vulnerability in the history display in Roundup before 1.4.20 allows remote attackers to inject arbitrary web script or HTML via a username, related to generating a link."}