{"action":"Upgrade roundup to 1.4.20 or later.","affected":[{"fixed":"1.4.20","introduced":"0"}],"component":"roundup","cve_ids":["CVE-2012-6131"],"ecosystem":"PyPI","epss":0.02,"exploited":false,"fixed_versions":["1.4.20"],"ghsa_id":"GHSA-gw2q-cgvq-9g3v","id":"tcs_01M5KG61HP2KX8CK41ZZYEG9WD","modified_at":"2026-06-10T17:02:33.959312453Z","published_at":"2014-04-11T15:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-16","http://www.openwall.com/lists/oss-security/2013/02/13/8","http://issues.roundup-tracker.org/issue2550711","http://www.openwall.com/lists/oss-security/2012/11/10/2","https://pypi.python.org/pypi/roundup/1.4.20","https://bugzilla.redhat.com/show_bug.cgi?id=722672","https://exchange.xforce.ibmcloud.com/vulnerabilities/84190","https://github.com/advisories/GHSA-gw2q-cgvq-9g3v"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-16","url":"https://osv.dev/vulnerability/PYSEC-2014-16"}],"summary":"Cross-site scripting (XSS) vulnerability in cgi/client.py in Roundup before 1.4.20 allows remote attackers to inject arbitrary web script or HTML via the @action parameter to support/issue1."}