{"action":"Upgrade django to 1.4.13 or later.","affected":[{"fixed":"1.4.13","introduced":"1.4"},{"fixed":"1.5.8","introduced":"1.5"},{"fixed":"1.6.5","introduced":"1.6"},{"fixed":"1.7b4","introduced":"1.7a0"}],"component":"django","cve_ids":["CVE-2014-3730"],"ecosystem":"PyPI","epss":0.03149,"exploited":false,"fixed_versions":["1.4.13","1.5.8","1.6.5","1.7b4"],"ghsa_id":"GHSA-vq3h-3q7v-9prw","id":"tcs_01M5KG62N7E5CVZTCK987X8JEX","modified_at":"2026-06-10T17:00:46.248439653Z","published_at":"2014-05-16T15:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-20","http://ubuntu.com/usn/usn-2212-1","https://www.djangoproject.com/weblog/2014/may/14/security-releases-issued/","http://www.openwall.com/lists/oss-security/2014/05/15/3","http://www.openwall.com/lists/oss-security/2014/05/14/10","http://www.debian.org/security/2014/dsa-2934","http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html","http://www.securityfocus.com/bid/67410","http://secunia.com/advisories/61281","https://github.com/advisories/GHSA-vq3h-3q7v-9prw"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-20","url":"https://osv.dev/vulnerability/PYSEC-2014-20"}],"summary":"The django.util.http.is_safe_url function in Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly validate URLs, which allows remote attackers to conduc"}