{"action":"Upgrade pillow to 2.3.1 or later.","affected":[{"fixed":"2.3.1","introduced":"0"}],"component":"pillow","cve_ids":["CVE-2014-1933"],"ecosystem":"PyPI","epss":0.00451,"exploited":false,"fixed_versions":["2.3.1"],"ghsa_id":"GHSA-r854-96gq-rfg3","id":"tcs_01M5KG633XK2HN4TEYFHT6SGRW","modified_at":"2023-11-08T03:57:35.856922Z","published_at":"2014-04-17T14:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-23","http://www.ubuntu.com/usn/USN-2168-1","http://www.openwall.com/lists/oss-security/2014/02/10/15","http://www.openwall.com/lists/oss-security/2014/02/11/1","https://github.com/python-imaging/Pillow/commit/4e9f367dfd3f04c8f5d23f7f759ec12782e10ee7","http://lists.opensuse.org/opensuse-updates/2014-05/msg00002.html","http://www.securityfocus.com/bid/65513","https://security.gentoo.org/glsa/201612-52","https://github.com/advisories/GHSA-r854-96gq-rfg3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-23","url":"https://osv.dev/vulnerability/PYSEC-2014-23"}],"summary":"The (1) JpegImagePlugin.py and (2) EpsImagePlugin.py scripts in Python Image Library (PIL) 1.1.7 and earlier and Pillow before 2.3.1 uses the names of temporary files on the command line, which makes"}