{"action":"Upgrade @cloudflare/workers-oauth-provider to 0.0.5 or later.","affected":[{"fixed":"0.0.5","introduced":"0"}],"component":"@cloudflare/workers-oauth-provider","cve_ids":["CVE-2025-4144"],"ecosystem":"npm","epss":0.00584,"exploited":false,"fixed_versions":["0.0.5"],"ghsa_id":"GHSA-qgp8-v765-qxx9","id":"tcs_01M5KG63N6CHA7AD6K0W3HGT0V","modified_at":"2025-05-01T17:42:09.225417Z","published_at":"2025-05-01T17:01:42Z","references":["https://osv.dev/vulnerability/GHSA-qgp8-v765-qxx9","https://github.com/cloudflare/workers-oauth-provider/security/advisories/GHSA-qgp8-v765-qxx9","https://nvd.nist.gov/vuln/detail/CVE-2025-4144","https://github.com/cloudflare/workers-oauth-provider/pull/27","https://github.com/cloudflare/workers-oauth-provider"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-qgp8-v765-qxx9","url":"https://osv.dev/vulnerability/GHSA-qgp8-v765-qxx9"},{"source":"nvd","source_id":"CVE-2025-4144","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-4144"}],"summary":"@cloudflare/workers-oauth-provider PKCE bypass via downgrade attack"}