{"action":"Upgrade python-keystoneclient to 0.2.4 or later.","affected":[{"fixed":"0.2.4","introduced":"0"}],"component":"python-keystoneclient","cve_ids":["CVE-2013-2104"],"ecosystem":"PyPI","epss":0.02082,"exploited":false,"fixed_versions":["0.2.4"],"ghsa_id":"GHSA-4rrr-j7ff-r844","id":"tcs_01M5KG6BJZX0BRA1J1BYN5HY5C","modified_at":"2026-06-10T17:02:31.786771479Z","published_at":"2014-01-21T18:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-69","https://bugs.launchpad.net/python-keystoneclient/+bug/1179615","http://www.openwall.com/lists/oss-security/2013/05/28/7","http://lists.opensuse.org/opensuse-updates/2013-06/msg00198.html","http://www.ubuntu.com/usn/USN-1875-1","http://rhn.redhat.com/errata/RHSA-2013-0944.html","http://www.ubuntu.com/usn/USN-1851-1","https://github.com/advisories/GHSA-4rrr-j7ff-r844"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-69","url":"https://osv.dev/vulnerability/PYSEC-2014-69"}],"summary":"python-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it"}