{"action":"Upgrade bottle to 0.10.12 or later.","affected":[{"fixed":"0.10.12","introduced":"0.8"},{"fixed":"0.11.7","introduced":"0.11"},{"fixed":"0.12.6","introduced":"0.12"}],"component":"bottle","cve_ids":["CVE-2014-3137"],"ecosystem":"PyPI","epss":0.03126,"exploited":false,"fixed_versions":["0.10.12","0.11.7","0.12.6"],"ghsa_id":"GHSA-873q-wpqr-xfgw","id":"tcs_01M5KG6DBWM6586NY8QJCKH816","modified_at":"2026-06-10T17:00:37.925134064Z","published_at":"2014-10-25T22:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-77","https://github.com/defnull/bottle/issues/616","https://bugzilla.redhat.com/show_bug.cgi?id=1093255","http://www.openwall.com/lists/oss-security/2014/05/01/15","http://www.debian.org/security/2014/dsa-2948","https://github.com/advisories/GHSA-873q-wpqr-xfgw"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-77","url":"https://osv.dev/vulnerability/PYSEC-2014-77"}],"summary":"Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted"}