{"action":"Upgrade logilab-common to 0.60.1 or later.","affected":[{"fixed":"0.60.1","introduced":"0"}],"component":"logilab-common","cve_ids":["CVE-2014-1838"],"ecosystem":"PyPI","epss":0.00343,"exploited":false,"fixed_versions":["0.60.1"],"ghsa_id":"GHSA-rr52-wg7f-8875","id":"tcs_01M5KG6EFNC9EWVQ5YTDFJTY5V","modified_at":"2023-11-08T03:57:35.186410Z","published_at":"2014-03-11T19:37:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-83","http://comments.gmane.org/gmane.comp.security.oss.general/11986","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=737051","http://secunia.com/advisories/57209","http://www.logilab.org/ticket/207561","http://lists.opensuse.org/opensuse-updates/2014-02/msg00085.html","https://github.com/advisories/GHSA-rr52-wg7f-8875"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-83","url":"https://osv.dev/vulnerability/PYSEC-2014-83"}],"summary":"The (1) extract_keys_from_pdf and (2) fill_pdf functions in pdf_ext.py in logilab-commons before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a"}