{"action":"Upgrade pillow to 2.5.0 or later.","affected":[{"fixed":"2.5.0","introduced":"0"}],"component":"pillow","cve_ids":["CVE-2014-3007"],"ecosystem":"PyPI","epss":0.10356,"exploited":false,"fixed_versions":["2.5.0"],"ghsa_id":"GHSA-8m9x-pxwq-j236","id":"tcs_01M5KG6F34P6PE21QQF45RSM12","modified_at":"2026-06-10T17:02:29.159885757Z","published_at":"2014-04-27T20:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-87","http://people.canonical.com/~ubuntu-security/cve/2014/CVE-2014-1932.html","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=737059","https://github.com/advisories/GHSA-8m9x-pxwq-j236"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-87","url":"https://osv.dev/vulnerability/PYSEC-2014-87"}],"summary":"Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibl"}