{"action":"Upgrade lxml to 3.3.5 or later.","affected":[{"fixed":"3.3.5","introduced":"0"}],"component":"lxml","cve_ids":["CVE-2014-3146"],"ecosystem":"PyPI","epss":0.06333,"exploited":false,"fixed_versions":["3.3.5"],"ghsa_id":"GHSA-57qw-cc2g-pv5p","id":"tcs_01M5KG6FKYH0HWBNAV4GFS5HSN","modified_at":"2026-06-10T17:00:40.512273712Z","published_at":"2014-05-14T19:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-9","http://lxml.de/3.3/changes-3.3.5.html","http://seclists.org/fulldisclosure/2014/Apr/210","http://www.securityfocus.com/bid/67159","http://www.openwall.com/lists/oss-security/2014/05/09/7","http://secunia.com/advisories/58013","http://seclists.org/fulldisclosure/2014/Apr/319","https://mailman-mail5.webfaction.com/pipermail/lxml/2014-April/007128.html","http://www.ubuntu.com/usn/USN-2217-1","http://lists.opensuse.org/opensuse-updates/2014-05/msg00083.html","http://secunia.com/advisories/58744","http://secunia.com/advisories/59008","http://www.mandriva.com/security/advisories?name=MDVSA-2015:112","http://advisories.mageia.org/MGASA-2014-0218.html","http://www.debian.org/security/2014/dsa-2941","https://github.com/advisories/GHSA-57qw-cc2g-pv5p"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-9","url":"https://osv.dev/vulnerability/PYSEC-2014-9"}],"summary":"Incomplete blacklist vulnerability in the lxml.html.clean module in lxml before 3.3.5 allows remote attackers to conduct cross-site scripting (XSS) attacks via control characters in the link scheme to"}