{"action":"Upgrade python-gnupg to 0.3.6 or later.","affected":[{"fixed":"0.3.6","introduced":"0.3.5"}],"component":"python-gnupg","cve_ids":["CVE-2014-1927"],"ecosystem":"PyPI","epss":0.03417,"exploited":false,"fixed_versions":["0.3.6"],"ghsa_id":"GHSA-r3vr-prwv-86g9","id":"tcs_01M5KG6FVEPJ3HVNHP5SBM77Y7","modified_at":"2023-11-08T03:57:35.612037Z","published_at":"2014-10-25T21:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-90","https://code.google.com/p/python-gnupg/issues/detail?id=98","http://seclists.org/oss-sec/2014/q1/294","https://code.google.com/p/python-gnupg/","http://secunia.com/advisories/59031","http://secunia.com/advisories/56616","http://seclists.org/oss-sec/2014/q1/245","http://www.debian.org/security/2014/dsa-2946","https://github.com/advisories/GHSA-r3vr-prwv-86g9"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-90","url":"https://osv.dev/vulnerability/PYSEC-2014-90"}],"summary":"The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as d"}