{"action":"Upgrade ajenti to 1.2.21.7 or later.","affected":[{"fixed":"1.2.21.7","introduced":"0"}],"component":"ajenti","cve_ids":["CVE-2014-4301"],"ecosystem":"PyPI","epss":0.02301,"exploited":false,"fixed_versions":["1.2.21.7"],"ghsa_id":"GHSA-2ch8-f849-pjg3","id":"tcs_01M5KG6HJXQ0G73G2JZ6XTBAJ0","modified_at":"2026-06-10T17:00:11.293302618Z","published_at":"2014-06-18T14:55:00Z","references":["https://osv.dev/vulnerability/PYSEC-2014-99","https://github.com/Eugeny/ajenti/commit/d3fc5eb142ff16d55d158afb050af18d5ff09120","http://secunia.com/advisories/59177","https://www.netsparker.com/critical-xss-vulnerabilities-in-ajenti","http://www.securityfocus.com/bid/68047","https://github.com/advisories/GHSA-2ch8-f849-pjg3"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2014-99","url":"https://osv.dev/vulnerability/PYSEC-2014-99"}],"summary":"Multiple cross-site scripting (XSS) vulnerabilities in the respond_error function in routing.py in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML vi"}